Cisco IOS Router | Enable configuration for KPN Customer Fiber Internet (KPN Glasvezel Particulier)

Few days ago. Me and my colleague were struggling with a configuration to enable internet access to a Fiber internet connection of KPN (it wasn’t a business line but a home user internet connection)

To enable this configuration. You can do the following:

On the internet interface (we used a HWIC-4ESW) the following commands. (With a business line the internet interface is not in a TRUNK mode).

interface FastEthernet0/3/1
 description CAP-ID INT Poortnummer met E-nmr
 switchport trunk allowed vlan 1,6 ( native should be there )
 switchport mode trunk
 mac-address <clone mac address of kpn experiabox>
 duplex full
 speed 100

Add a VLAN interface with the number 6. (You use an different interface first you can look to the VDSL Configuration

interface Vlan6
 no ip address
 load-interval 30
 pppoe enable group global
 pppoe-client dial-pool-number 12

This dialer interface is pretty standard for a pppoe configuration

interface Dialer12
 description Customer Traffic PPPoE Connection
 mtu 1492
 ip address negotiated
 ip verify unicast reverse-path
 no ip redirects
 no ip proxy-arp
 ip nat outside
 no ip virtual-reassembly
 encapsulation ppp
 dialer pool 12
 dialer-group 12
 no cdp enable
 ppp pap sent-username <mac address KPN Experiabox>@direct-adsl password KPN
 ppp ipcp mask request
 ppp ipcp address accept

This internet interface had a 100mb/s download and upload.

Leave a Reply

Fill in your details below or click an icon to log in: Logo

You are commenting using your account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s