Cisco | SMB Switch SF 302-8P Configuration for wireless APs and Guest-LAN

Few days ago I configured a SF-302-8P cisco switch for usage of WiFi and a guest-LAN. To relize this solution i had to configure a few VLANs.
A tip before you start upgrade to the last version of this Switch because than you have the most commond CLI commands in this switch. If you have an older version than you don’t have a nice CLI like in the new Software version.

I figured out that configuring VLAN’s on the CLI was much easier than via the HTTP. So as advice I would give when you use VLAN’s use the CLI instead of the HTTP.

Below you will find a sample configuration for a WiFi solution and a guest-lan.

v1.2.9.44 / R750_NIK_1_2_584_002
CLI v1.0
file SSD indicator encrypted
ssd config
ssd file passphrase control unrestricted
no ssd file integrity control
ssd-control-end <encrypted code>
vlan database
vlan 2,666
voice vlan oui-table add 0001e3 Siemens_AG_phone________
voice vlan oui-table add 00036b Cisco_phone_____________
voice vlan oui-table add 00096e Avaya___________________
voice vlan oui-table add 000fe2 H3C_Aolynk______________
voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone
voice vlan oui-table add 00d01e Pingtel_phone___________
voice vlan oui-table add 00e075 Polycom/Veritel_phone___
voice vlan oui-table add 00e0bb 3Com_phone______________
ip igmp snooping
ip igmp snooping vlan 1
ip igmp snooping vlan 2
hostname < hostname >
username cisco password encrypted <encrypted password privilege 15
ip ssh server
clock timezone " " 1
clock summer-time web recurring eu
clock source sntp
sntp unicast client enable
sntp unicast client poll
sntp server <NTP server>
ip telnet server
interface vlan 1
ip address <ip address>
no ip address dhcp
interface vlan 2
name MY-Guests
interface vlan 666
name WIFI
interface fastethernet1
description Cisco-AP-1042-office
switchport trunk allowed vlan add 2,666
interface fastethernet2
description Cisco-AP-1042-hall
switchport trunk allowed vlan add 2,666
interface fastethernet3
description Cisco-AP-1042-showroom
switchport trunk allowed vlan add 2,666
interface fastethernet8
description Guest-Lan
switchport mode access
switchport access vlan 2
interface gigabitethernet1
description Cisco-WLC-2504
switchport trunk allowed vlan add 2,666
interface gigabitethernet2
description Cisco-to-<other switch>
ip default-gateway < router gateway >

More information about these serie of the Switch:

Leave a Reply

Fill in your details below or click an icon to log in: Logo

You are commenting using your account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s