Cisco catalyst switch ( ether channel settings ) to VMWare ESXi 5

Earlier this year I made a trunk connection between HP Procurve switch and a VMWare ESXi5. But now i’ve created a connection between a Cisco Catalyst Switch 3750 and a VMWare ESXi5

To do this you have to go to the configuration of you ESX Server and than the Network properties. Choose the vSwitch you want to configure with the trunk/Ether-channel to the Catalyst switch.

Choose like below the vSwitch and go to the TAB NIC Teaming
Put the Load Balancing on Route based on IP Hash
Click on apply / OK. Go than to the Management Network

At the Management network you have to configured the same settings as you did with the vSwitch.

Now we have to configure the Cisco Catalyst Switch.

Go to the configuration mode of the switch [ PACP Configuration ]
Clear the configuration of 2 Gigabit Ethernet ports.
default interface g1/0/44
default interface g1/0/47

int range g 1/0/44, g 1/0/47
 channel-group 2 mode on

Configure the ports with the following configuration ( you can to this with the int range <interface> , <interface> command)

interface GigabitEthernet1/0/44
 switchport mode access
 switchport nonegotiate
 spanning-tree portfast
 channel-group 2 mode on

interface GigabitEthernet1/0/47
 switchport mode access
 switchport nonegotiate
 spanning-tree portfast
 channel-group 2 mode on

Configure the Port Channel inteface

interface Port-channel2
description connectie-naar-ESX
switchport mode access
switchport nonegotiate
spanning-tree portfast
spanning-tree guard loop

Note: If you missed one of the steps in ESX you lose your connection with your ESX server. Be aware of this.
Note: removed Flowcontrol receive on because it cause issues on your port-channel
Cisco URL: http://www.cisco.com/en/US/tech/tk389/tk213/technologies_tech_note09186a0080094714.shtml#catalyst

2 thoughts on “Cisco catalyst switch ( ether channel settings ) to VMWare ESXi 5

  1. You have to set the load balancing method on the switch as well, using port-channel load-balance and set it to “src-dst-ip” which matches what ESXi uses:
    #port-channel load-balance src-dst-ip
    Note that you can’t specify how aggregated links are being loadbalanced per port-channel, so you need to take that into account when you have other port-channels.

  2. That command I haven’t seen before well I’m going to take configure that aswell ( I’ve more ether-channel configurations on the same switch now )

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s