HP Procurve 2910 Switch (routing configuration)

1:     login to the switch through TELNET OR SSH

2:    Standard configuration does not contain a password

3:    type configure terminal

4:    type a hostname “name of the switch”.

5:    Type vlan 1 and configure an ip address

6:    Enter a default gateway

7:    type ip routing & default route “ip route x.x.x.x”

When you enable routing, and default route. Your clients get a new default gateway. (The switch will act as gateway for the clients.)

With this configuration you will be able to browse to other Vlan’s on the switch.

8:    configure spanning-tree

9:    create a new VLAN (example. Vlan 100 )

10:    Give the new VLAN an IP Address

11:    Untag ports on the siwtch which you want to use for the new VLAN

When you finished the configuration and you run “show running-config” you will see a configuration like below.

12:    show running-config

20 thoughts on “HP Procurve 2910 Switch (routing configuration)

    • HP switches don’t have an IOS version.
      The software version of the switch is W.14.38 how ever I recommend to upgrade to the latest software version of the HP 29210

  1. any reason why i cant routed between vlans when using a dhcp server and helper?


    • You have 2 options in this case.
      1. you let your router preform the routing options between the 2 subnets
      2. you put your switch as default gateway for all internal hosts.

      • Because you need a device who is able to access the internet. And not items not the same with the default gateway other networks won’t find unspecified networks

  2. if i replace the X.X.X.X in your tutorial:
    hostname “SW”

    ip default-gateway
    ip routing

    vlan 1
      name “DEFAULT_VLAN”
      untagged 2-28
      ip address
    no untagged 1
    vlan 2
      name “vlanone”
      untagged 1
      ip address

    ip route

    (fake IP but it’s for see where is the router and primary ip must to be).
    it’s correct?

    • Correct and on the route you need a route who points to the ip of the switch a non route

      If you need toy route between the LANs on the switch than you need ip routing.

      With the ip routing 1 disadvantage will show up that you are not able to create trunks. Maybe it’s fixed in newer software updates. But at the time of this written content it wasn’t possible.

      • Humm..
        “Correct and on the route you need a route who points to the ip of the switch a non route”
        can you show me an ip route example for this ?

      • What kind of device are you using for the gateway?
        in the ip address example you use. you need to make an route on the gateway device like.

        cisco iOS “ip route”
        cisco ASA “route inside”

        You might be able to use a routing protocol like ospf or rip. (I was supposing to time EIGRP but this is not possible because it cisco proprietary). Than you won’t have to think about static routes on the gateway device.

        I use incase of cisco equipment EIGRP on the gateway device and on the L3 switch behind the cisco devices (both are cisco manufactured) this solves me a lot of maintenance on multiple devices. :)

      • I use a HP 2920, with the hp v1910 i’m able to do what i want but there are a limitation (8 vlan interfaces).
        Cogent give me a /30 and i need to set the switch on this /30 and use the router as router for the server connected in the vlan.

      • you use the switch as default gateway for the internal LAN devices.. Than you need ip routing on the switch enabled. otherwise you won’t be able to communicate between the vlan’s.

        Cogent is the ISP? I think? so they give you a /30 address but you are not going to use any firewalling etc?
        I guess you have 1 external IP address given by the ISP ( Cogent ) and you need to translate it into internal addresses? Incase this I would suggest to look for a router (non-switch) or firewall device to make the connection with the ISP and to translate it back into your normal network. This would make it easier for you to maintain the configuration of the netwerk :)

      • Cogent is the ISP, i have a /22 ip block for my servers. I don’t have the knowledge for configure a router and it’s diffcult to find a qualified person for do that.
        With the V1910 it’s works good: i set
        switch gate: (cogent router)
        switch ip: (public ip)
        gateway of vlan
        ip of vlan:

        for server in the vlan:

        but with the 2910 it’s more difficult :/.

  3. In idea, can you have a reference of Cisco router for small infrastructure? (and easy to configure).

    • On your previous reply. it should be more easy on the 2910 than on the 1910 (that in my case) this is because of the older cli on that device. where the 1910 has the former 3Com cli.

      how ever on you second question. i suggest to look at a router the http://www.cisco.com/smb line. how ever you could think of using a draytek instead. It might be easier to configure. I would suggest to take the 2960 model of Draytek.

      All the cisco devices has a web interface. how ever the models from the c800 series and up ( like the 1900 / 2900 ) has better functionality on CLI.

      • Ok thanks !
        I try the solution for 2910 and if it’s don’t work i buy a Cisco router.

      • hello,

        all is good! i have set Cogent router for defaut route and it’s work.
        but i need to add the default route before enable ip routing or the switch say it’s not possible to set switch ip for default route (i set the first vlan with /30 of Cogent).
        For information if visitor need example:

        hostname “HP-2920-48G”
        module 1 type j9728a
        no web-management
        web-management ssl
        ip default-gateway
        ip route
        ip routing
        snmp-server community “public” unrestricted
        snmp-server enable traps snmp-authentication standard
        no snmp-server enable traps snmp-authentication extended
        ip address dhcp-bootp
        router rip
        redistribute connected
        vlan 1
        name “DEFAULT_VLAN”
        no untagged 1-12,23-44
        untagged 3-22,45-48,A1-A2,B1-B2
        ip address
        vlan 2
        name “xx1”
        untagged 1
        ip address
        vlan 3
        name “xx2”
        untagged 2
        ip address
        vlan 20
        name “IPMI”
        untagged 23-44
        ip address
        no autorun
        no dhcp config-file-update
        no dhcp image-file-update
        password manager
        password operator


Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s