Cisco Router 878 in a SHDSL mode and bridged.

Yesterday during my work i configured a router what may be is useful to use when you need to configure a router in bridge mode. When you have a Dialer interface. PPPoA connection…

The example configuration is based on a cisco router 878 but parts of the configuration are also able to use with a Cisco ADSL Router like an 877 or an 878.

Building configuration…

Current configuration : 4049 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime
service password-encryption
!
hostname < Routername >
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
no logging rate-limit
enable secret < password >
!
aaa new-model
!
!
aaa authentication login default local
aaa authentication ppp default local
aaa authorization network default local
!
aaa session-id common
!
resource policy
!
clock timezone GMT+1 1
clock summer-time GMT+1 recurring last Sun Mar 2:00 last Sun Oct 3:00
ip subnet-zero
no ip source-route
ip cef
!
!
!
!
ip domain name < domainname >
ip name-server < dns 1 >
ip name-server < dns 2 >
ip ssh rsa keypair-name RSA_SSH
no ip ips sdf builtin
!
!
!
username <username>  privilege 15 secret 5 <password>

!
!
controller DSL 0
 mode atm
 line-term cpe
 line-mode 2-wire line-zero
 dsl-mode shdsl symmetric annex B
 line-rate auto
!
no crypto isakmp enable
!
!
!
!
interface BRI0
 no ip address
 encapsulation hdlc
 shutdown
!
interface ATM0
 no ip address
 no atm ilmi-keepalive
 pvc 0 0/35
  encapsulation aal5mux ppp dialer
  dialer pool-member 10
 !
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan1
 description connected to Cisco Pix 506, WAN
 ip address < IP address / Subnet range >
 no ip proxy-arp
!
interface Dialer10
 description connected to ATM0 – SDSL
 ip unnumbered Vlan1
 encapsulation ppp
 dialer pool 10
 dialer-group 10
 no cdp enable
 ppp authentication pap callin
 ppp pap sent-username < login name  > password < password >
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer10 100 permanent
!
!
no ip http server
no ip http secure-server
ip nat inside source route-map ADSL interface Dialer10 overload
!
access-list 11 remark ———————————————————-
access-list 11 remark IP inspect OUT java-list
access-list 11 permit any
access-list 21 permit < ip add >
access-list 21 remark ———————————————————-
access-list 21 remark SNMP & Telnet
access-list 21 remark ———————————————————-
access-list 21 permit < ip range remote ssh >
access-list 21 permit < ip range remote ssh >
dialer-list 10 protocol ip permit
snmp-server community mrtg RO 21
snmp-server location < location information >
snmp-server contact < contact information >
snmp-server enable traps tty
no cdp run
!
!
control-plane
!
banner motd #
*************************************************************
This system is restricted to authorized users for legitimate
purposes and is subject to audit. The unauthorized access,
use or modification of computer systems or the data contained
therein or in transit to/from, may be illegal.
                                                                                
Contact information:                                                    
< Contact information >                                                 
*************************************************************
#
!
line con 0
 exec-timeout 120 0
 password < password >
 no modem enable
line aux 0
line vty 0 4
 exec-timeout 120 0
 privilege level 15
 password < password >
 transport input telnet ssh
!
scheduler max-task-time 5000
scheduler allocate 20000 1000
ntp clock-period 17179872
sntp server 145.24.129.6
sntp server 213.239.154.12
sntp server 193.79.237.14
sntp broadcast client
end

One thought on “Cisco Router 878 in a SHDSL mode and bridged.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s