Configure a Cisco Router for Bridge usage

Below a configuration of a cisco router in bridge mode the pvc is used for a Dutch ISP 

service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime
service password-encryption

hostname < Router Naam >


logging buffered 51200 warnings
no logging rate-limit
enable secret < The Password >

aaa new-model
aaa authentication login default local
aaa authentication ppp default local
aaa authorization network default local

aaa session-id common

resource policy

clock timezone GMT+1 1
clock summer-time GMT+1 recurring last Sun Mar 2:00 last Sun Oct 3:00
no ip source-route
no ip routing
no ip cef
ip domain name < domein naam >
no ip ips sdf builtin

username <username> password < password >
no crypto isakmp enable

bridge irb

interface BRI0
 no ip address
 encapsulation hdlc
 no ip route-cache

interface ATM0
 description < line description >
 no ip address
 no ip route-cache
 no atm ilmi-keepalive
 pvc 0/35
  encapsulation aal5snap
 dsl operating-mode auto
 bridge-group 10
interface FastEthernet0

interface FastEthernet1

interface FastEthernet2

interface FastEthernet3

interface Vlan1
 no ip address
 no ip route-cache
 bridge-group 10
 hold-queue 100 out

no ip http server
no ip http secure-server

no cdp run


bridge 10 protocol ieee
banner motd #
          |               |                                 
         |||             |||                                
       .|||||.         .|||||.                              
    .:|||||||||:. . .:|||||||||:.                           
      C i s c o     S y s t e m s                             
This system is restricted to authorized users for legitimate
purposes and is subject to audit. The unauthorized access,
use or modification of computer systems or the data contained
therein or in transit to/from, may be illegal.

line con 0
 exec-timeout 120 0
 password < password >
 no modem enable
line aux 0
line vty 0 4
 exec-timeout 120 0
 privilege level 15
 password < Password >
 transport input telnet ssh

scheduler max-task-time 5000

webvpn context Default_context
 ssl authenticate verify all
 no inservice


Leave a Reply

Fill in your details below or click an icon to log in: Logo

You are commenting using your account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s