Basic Voice Router Configuration with SRST and Unity Express

Below, a configuration with the basics of a voice router configuration. The Configuration is Based on H.323 and not MCGP
Router configuration was :

Cisco 2821 (revision 53.51) with 249856K/12288K bytes of memory.
2 Gigabit Ethernet interfaces
31 Serial interfaces
2 ISDN Basic Rate interfaces
1 terminal line
1 Channelized E1/PRI port
4 Voice FXS interfaces
1 cisco service engine(s)
DRAM configuration is 64 bits wide with parity enabled.
239K bytes of non-volatile configuration memory.
62720K bytes of ATA CompactFlash (Read/Write) 

————————————————————————
Building configuration…

Current configuration : 3718 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname < Router Name >
!
boot-start-marker
boot-end-marker
!
card type e1 0 1
logging buffered 500000 debugging
enable secret < your password >
!
no aaa new-model
!
resource policy
!
network-clock-participate wic 1
network-clock-participate wic 2
network-clock-select 1 E1 0/1/0
!
!
ip cef
no ip dhcp use vrf connected
!
ip dhcp pool < DHCP Pool Name .
   network 1< Ip Range you want to use >
   option 150 ip < call Manager IP Address > 
   default-router < Router ip address > 
!
!
no ip domain lookup
!
isdn switch-type primary-net5
!
voice-card 0
 no dspfarm
!
!
voice call convert-discpi-to-prog
!
voice service voip
 modem passthrough nse codec g711alaw
!
!
voice class codec 1
 codec preference 1 g711alaw
 codec preference 2 g711ulaw
 codec preference 3 g729r8
!
!
!
!
!
!
!
!
!
!
!
voice translation-rule 1
 rule 1 // /0/ type national national
 rule 2 // /00/ type international international
!
!
voice translation-profile outside-inside
 translate calling 1
!
!
!
!
username < username > secret < password >
archive
 log config
  hidekeys
!
!
controller E1 0/1/0
 framing NO-CRC4
 pri-group timeslots 1-31
!
!
!
!
interface GigabitEthernet0/0
 description *** VOICE ***
 ip address < IP Address for the Router >
 ip helper-address < DHCP server IP address >
 duplex auto
 speed auto
!
interface Service-Engine0/0
 ip address < IP address of the service Module Gateway >
 service-module ip address < Ip address of the Module >
 service-module ip default-gateway < IP address of service module Gateway >
!
interface GigabitEthernet0/1
 ip address < Connection to an other subnet ip address + Subnet mask >
 duplex auto
 speed auto
!
interface Serial0/1/0:15
 no ip address
 encapsulation hdlc
 isdn switch-type primary-net5
 isdn incoming-voice voice
 no cdp enable
!
interface BRI0/2/0
 no ip address
 isdn switch-type basic-net3
 isdn point-to-point-setup
!
interface BRI0/2/1
 no ip address
 isdn switch-type basic-net3
 isdn point-to-point-setup
!
router eigrp 20
 network < Network address 1 >
 network < Network Address 2 >
 no auto-summary
!
ip route 0.0.0.0 0.0.0.0 < 0. route for internet connection >
ip route < Network address + subnetmask >  Service-Engine0/0
!
ip http server
no ip http secure-server
!
!
!
!
control-plane
!        
!
!
voice-port 0/0/0
 cptone NL
!
voice-port 0/0/1
 cptone NL
!
voice-port 0/0/2
 cptone NL
!
voice-port 0/0/3
 cptone NL
!
voice-port 0/1/0:15
 translation-profile incoming outside-inside
 cptone NL
!
voice-port 0/2/0
!
voice-port 0/2/1
!
ccm-manager fallback-mgcp
!
no mgcp timer receive-rtcp
no mgcp explicit hookstate
!
!
dial-peer cor custom
!
!
!
dial-peer voice 1000 pots
 destination-pattern 0.T
 direct-inward-dial
 port 0/1/0:15
!
dial-peer voice 2000 voip
 destination-pattern <phonenumber without a 0>.
 voice-class codec 1
 session target ipv4:< call Manager Gateway>
 dtmf-relay h245-alphanumeric
!
dial-peer voice 1001 pots
 incoming called-number <phonenumber without a 0>.
 direct-inward-dial
 forward-digits all
!
dial-peer voice 1002 pots
 translation-profile incoming outside-inside
 destination-pattern < Fax Number >
 port 0/0/0
!
dial-peer voice 1010 pots
 preference 9
 destination-pattern 0.T
 direct-inward-dial
 port 0/2/0
!
dial-peer voice 1011 pots
 preference 10
 destination-pattern 0.T
 direct-inward-dial
 port 0/2/1
!
!
!
call-manager-fallback
 max-conferences 8 gain -6
 transfer-system full-consult
 ip source-address < Ip address of the ROuter > port 2000
 max-ephones 52
 max-dn 192
!
!
line con 0
 exec-timeout 120 0
line aux 0
line 194
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
line vty 0 4
 exec-timeout 120 0
 password < Password >
 login
!
scheduler allocate 20000 1000
!
end    

Advertisements

3 thoughts on “Basic Voice Router Configuration with SRST and Unity Express

  1. Hi,
    I’m experimenting with 2811, CME, H.323 and callmanager, but no luck so far.
    The configuration file is just the same (except the interface configuration), but the phones doesn’t see any “standby” SRST callmanager at all. They are connected to the callmanager successfully via H323, and when I unplug the callmanager’s wire – the phones are in “configuring IP” or “configuring CM list” state…

    Do you see the cisco router as second stand-by callmanager in the phones network settings during normal operation?

    Regards

    • Hello,
      They configuration we used. was the router was the main router for incoming and outgoing calls which where redirect to the Cisco CM.
      The Router was also the SRST for the Call Manager.

      Did you have the full configuration into the router?
      It’s wierd. i can’t test it at the moment but if i have the possibility to test it i will let you know.
      I remember when i tested it. It worked.

      I hope the telephones has as Gateway the router ? can you check that

      cheers

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s